LoadAVG currently requires a LAMP stack to work, however it does not require MySQL to function so a working database is not necessary.

Main requirements are:

Apache v1.0 and up
PHP v5.0 and up with exec() support

LoadAvg currently supports all flavours of linux and runs on PHP V5 and up. To ensure proper functionality you need to make sure that PHP safe mode off or the script is added to your safe mode exclusions.